poj 1195 Mobile phones

Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 18729 Accepted: 8641

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

提示

题意:

有个s*s(1<=s<=1024)的矩阵,我们有四个操作:

0.矩阵上的所有数清零。(只有一次且在开头)

1.点(x,y)加上一个数A(-32768<=A<=32767)

2.输出区间c[B][L]~c[T][R]的和

3.结束程序

思路:

单点更新区间查询,标准的树状数组(二维),坐标从零开始,我们需要把横纵坐标都加1。

下面给出二维树状数组的代码(来源于书):

给c[i][j]这一结点加上k:

void update(int i,int j,int k)
{
    while(i<=n)
    {
        int temp=j;
        while(temp<=n)
        {
            c[i][temp]+=k;
            temp+=lowbit(temp);
        }
        i+=lowbit(i);
    }
}
下面的代码查询c[1][1]~c[i][j]的和:

int sum(int i,int j)
{
    int sum=0;
    while(i>0)
    {
        int temp=j;
        while(temp>0)
        {
            sum+=c[i][temp];
            temp-=lowbit(temp);
        }
        i-=lowbit(i);
    }
    return sum;
}

求区间c[x1][y1]~c[x2][y2]的代码如下:

SUM=sum(x2,y2) - sum(x1-1,y2) - sum(x2,y1-1) + sum(x1-1,y1-1)

示例程序

Source Code

Problem: 1195		Code Length: 988B
Memory: 4504K		Time: 1094MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int c[1025][1025];
int lowbit(int x)
{
    return x&(-x);
}
void updata(int x,int y,int a,int n)
{
    int i,i1;
    for(i=x;n>=i;i=i+lowbit(i))
    {
        for(i1=y;n>=i1;i1=i1+lowbit(i1))
        {
            c[i][i1]=c[i][i1]+a;
        }
    }
}
int sum(int x,int y)
{
    int i,i1,sum=0;
    for(i=x;i>=1;i=i-lowbit(i))
    {
        for(i1=y;i1>=1;i1=i1-lowbit(i1))
        {
            sum=sum+c[i][i1];
        }
    }
    return sum;
}
int main()
{
    int n,i,i1,l,r,b,t,x,y,a,step;
    scanf("0 %d",&n);
    memset(c,0,sizeof(c));
    while(scanf("%d",&step)!=EOF&&step!=3)
    {
        if(step==1)
        {
            scanf("%d %d %d",&x,&y,&a);
            updata(x+1,y+1,a,n);
        }
        else
        {
            scanf("%d %d %d %d",&l,&b,&r,&t);
            l++;
            b++;
            r++;
            t++;
            printf("%d\n",sum(r,t)-sum(r,b-1)-sum(l-1,t)+sum(l-1,b-1));
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值