(模板题)poj 3264 Balanced Lineup(RMQ的ST算法)


Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 49596 Accepted: 23232
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

提示

题意:

给出一长度为N(1<=N<=50000)的数列,对该数列进行Q(1<=Q<=200000)次询问,求出[a,b]区间最大值与最小值的差。

思路:

ST算法基础题,了解原理套模板。

ST的讲解:http://blog.csdn.net/insistgogo/article/details/9929103

示例程序

Source Code

Problem: 3264		Code Length: 1184B
Memory: 6860K		Time: 3563MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <math.h>
int a[50000],f[2][50000][16];
int max(int x,int y)
{
    if(x>y)
    {
        return x;
    }
    else
    {
        return y;
    }
}
int min(int x,int y)
{
    if(x<y)
    {
        return x;
    }
    else
    {
        return y;
    }
}
void bulid(int n)
{
    int i,i1,logn;
    for(i=0;n>i;i++)
    {
        f[0][i][0]=a[i];
        f[1][i][0]=a[i];
    }
    for(i=1;n>=(1<<i);i++)
    {
        for(i1=0;n>i1+(1<<i)-1;i1++)
        {
            f[0][i1][i]=max(f[0][i1][i-1],f[0][i1+(1<<(i-1))][i-1]);
            f[1][i1][i]=min(f[1][i1][i-1],f[1][i1+(1<<(i-1))][i-1]);
        }
    }
}
int rmq(int x,int y,int flag)
{
    int logn;
    logn=(int)(log((double)(y-x+1))/log(2.0));
    if(flag==0)
    {
        return max(f[0][x][logn],f[0][y-(1<<logn)+1][logn]);
    }
    else
    {
        return min(f[1][x][logn],f[1][y-(1<<logn)+1][logn]);
    }
}
int main()
{
    int n,q,i,x,y;
    scanf("%d %d",&n,&q);
    for(i=0;n>i;i++)
    {
        scanf("%d",&a[i]);
    }
    bulid(n);
    for(i=1;q>=i;i++)
    {
        scanf("%d %d",&x,&y);
        x--;
        y--;
        printf("%d\n",rmq(x,y,0)-rmq(x,y,1));
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值