poj 1703 Find them, Catch them


Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 43197 Accepted: 13278

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source

提示

解析来源于书。

题意:

Tadu City 里面有两个黑帮团伙Gang Dragon 和 Gang Snake,一共有n名团伙成员(还不知道属于这两个黑帮的哪一个)。现在警察局有一些信息,每条信息包含2个人编号,表示这2个人属于不同的帮派。问给出2个人的编号,能否确定他们是否属于同一帮派。

思路:

典型的并查集的题目,有人可能会想:只需两个集合表示两个团伙,仔细想想,这样不好。当给出(1,2),(5,6)和(1,5),这样2和5属于同一个集合,1和6属于同一个集合,怎么表示呢。刚开始(1,2)可能将1和2都Make_Set(),但没有记录下1和2属于不同团队,下次(1,5)的时候不能找到应该将2和5合并的信息。介绍一种常用的作法,希望读者掌握:只要两者关系确定了,就将它们放入同一集合内,而另外增加一个表示关系的数组rela[]来表示该结点与其父亲的关系,0表示同一类,1表示不同团伙。初始时集合只有自己一个元素,rale设置为0。

示例程序

Source Code

Problem: 1703		Code Length: 1479B
Memory: 1168K		Time: 704MS
Language: GCC		Result: Accepted
#include <stdio.h>
int a[100000],relation[100000];
int find(int x)
{
    int pos;
    if(a[x]==x)
    {
        return x;
    }
    pos=a[x];
    a[x]=find(a[x]);
    if(relation[x]==relation[pos])
    {
        relation[x]=0;
    }
    else
    {
        relation[x]=1;
    }
    return a[x];
}
int main()
{
    int n,i,t,i1,x,y,fx,fy,m;
    char s[2];
    scanf("%d",&t);
    for(i=1;t>=i;i++)
    {
        scanf("%d %d",&n,&m);
        for(i1=0;n>i1;i1++)
        {
            a[i1]=i1;
            relation[i1]=0;
        }
        for(i1=1;m>=i1;i1++)
        {
            scanf("%s %d %d",s,&x,&y);
            fx=find(x);
            fy=find(y);
            if(s[0]=='A')
            {
                if(fx!=fy)
                {
                    printf("Not sure yet.\n");
                }
                else if(relation[x]==relation[y])
                {
                    printf("In the same gang.\n");
                }
                else
                {
                    printf("In different gangs.\n");
                }
            }
            else
            {
                if(fx!=fy)
                {
                    a[fx]=fy;
                    if(relation[x]==relation[y])
                    {
                        relation[fx]=1;
                    }
                    else
                    {
                        relation[fx]=0;
                    }
                }
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值