poj 2559 Largest Rectangle in a Histogram

Largest Rectangle in a Histogram
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21453 Accepted: 6906

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where  0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

Source

提示

题意:

有n个(1<=n<=100000)宽为1矩形高为h(0<=h<=1000000000)依次排列着,求出最大矩阵的面积。

思路:

需要借助单调栈(不递减)来完成。

当前元素入栈时,连着当前元素的位置也都记录下来。

当前元素先不入栈时,算出当前元素的位置与栈顶元素的位置作差再乘上栈顶元素的值,直到栈为空或者大于等于栈顶元素。之后该元素入栈,但它的位置就不进行记录。

示例程序

#include <cstdio>
using namespace std;
struct jj
{
    long long d,pos;
}sta[100000];
int main()
{
    long long n,i,a[100000],top,maxx,t;
    while(scanf("%lld",&n)!=EOF&&n!=0)
    {
        for(i=0;n>i;i++)
        {
            scanf("%lld",&a[i]);
        }
        top=0;
        maxx=0;
        for(i=0;n>i;i++)
        {
            if(top==0||sta[top-1].d<=a[i])			//栈顶没有元素或者大于等于栈顶元素
            {
                sta[top].d=a[i];
                sta[top].pos=i;
                top++;
            }
            else
            {
                while(top>=1&&sta[top-1].d>a[i])		//弹出栈顶元素,直到栈顶没有元素或者当前元素大于等于栈顶元素
                {
                    t=sta[top-1].d*(i-sta[top-1].pos);
                    if(t>maxx)
                    {
                        maxx=t;
                    }
                    top--;
                }
                sta[top].d=a[i];
                top++;
            }
        }
        while(top>=1)		//处理栈中剩余元素
        {
            t=sta[top-1].d*(n-sta[top-1].pos);
            if(t>maxx)
            {
                maxx=t;
            }
            top--;
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值