ACM练习3*n+1问题

题目描述

Consider the following algorithm to generate a sequence of numbers. Start with an integer n. If n is even, divide by 2. If n is odd, multiply by 3 and add 1. Repeat this process with the new value of n, terminating when n = 1. For example, the following sequence of numbers will be generated for n = 22: 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 It is conjectured (but not yet proven) that this algorithm will terminate at n = 1 for every integer n. Still, the conjecture holds for all integers up to at least 1, 000, 000. For an input n, the cycle-length of n is the number of numbers generated up to and including the 1. In the example above, the cycle length of 22 is 16. Given any two numbers i and j, you are to determine the maximum cycle length over all numbers between i and j, including both endpoints.

输入

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

输出

For each pair of input integers i and j, output i, j in the same order in which they appeared in the input and then the maximum cycle length for integers between and including i and j. These three numbers should be separated by one space, with all three numbers on one line and with one line of output for each line of input.

样例输入

1 10
100 200
201 210
900 1000

样例输出

1 10 20
100 200 125
201 210 89
900 1000 174

提示

杭电1032

这是题目,大概意思是对于一个数,如果这个数的是偶数,就除以2,如果是奇数就乘以3然后加上1,直到最终结果为1为止,这个规律对于任何数都成立,记录从开始到1的步骤,要求输入一个数,i和j,求出这两个数之间步骤最少的一个。没有告诉一共输入多少组。

我应该注意的是:不是把所有的输入都输入完成,然后做个总的输出,而是每个输入对应一组输出。

#include<stdio.h>
int main()
{
       int i,j,k,k2,max=0,count=0,tem,j1,j2;
       while(scanf("%d %d",&i,&j)!=EOF)//这里不能改成while(1),改后会提示超出限制
       {
           max=0;
           j1=i;
           j2=j;
           if(i>j)//这里必须判断大小,不能看例子都是i小于j的所以就自以为是i<j
           {
                tem=i;
                i=j;
                j=tem;
           }
           for(k=i;k<=j;k++)
           {
               for(k2=k,count=1;count==0||k2!=1;count++)
               {
                   if(k2%2==0)
                   {
                       k2=k2/2;
                   }
                   else
                   {
                       k2=k2*3+1;
                   }
                }
                 if(count>max)
                {
                    max=count;
                }
           }
            printf("%d %d %d\n",j1,j2,max);
       }
    return 0;
}






  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值