寒假训练补题-第十天--J0-单源最短路径

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Bessie在外地,想要回到谷仓,尽可能多地睡觉,然后Farmer John在早上挤奶时将她叫醒。贝茜需要她的美丽睡眠,所以她想尽快回来。

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Farmer John的场地中有N(2 <= N <= 1000)个地标,唯一编号为1…N。地标1是谷仓;Bessie整天站立的苹果树林是具有里程碑意义的N.奶牛在田间旅行时使用T(1 <= T <= 2000)双向牛尾迹,各种长度的地标之间。Bessie对她的导航能力没有信心,所以一旦她开始,她总是会从开始到结束。

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

鉴于地标之间的路径,确定贝西必须走的最小距离才能回到谷仓。保证存在一些这样的路线。

Input

  • Line 1: Two integers: T and N
  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

输入
第1行:两个整数:T和N.
行2…T + 1:每行描述一个以三个以空格分隔的整数的轨迹。前两个整数是小道行进的地标。第三个整数是路径的长度,范围是1…100。

Output
Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
产量
第1行:一个整数,是Bessie从地标N到地标1必须经过的最小距离。

Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

个人思路:网上的思路
ac代码:

#include<stdio.h>
#define Max 0x3fffffff
int map[1005][1005];
int dis[1005];

void dijkstra(int n)
{
	int visit[1001] = { 0 };
	visit[1] = 1;
	int min, i, j, k;
	for (i = 1; i < n; ++i)
	{
		min = Max;
		k = 1;
		for (j = 1; j <= n; ++j)
		{
			if (!visit[j] && min > dis[j])
			{
				min = dis[j];
				k = j;
			}
		}
		visit[k] = 1;
		for (j = 1; j <= n; ++j)
		{
			if (!visit[j] && dis[j] > dis[k] + map[k][j])
				dis[j] = dis[k] + map[k][j];
		}
	}
	printf("%d\n", dis[n]);
}

int main()
{
	int t, n, i, j, from, to, cost;
	while (scanf("%d%d", &t, &n) != EOF)
	{
		for (i = 1; i <= n; ++i)
		{
			map[i][i] = 0;
			for (j = 1; j < i; ++j)
				map[i][j] = map[j][i] = Max;
		}
		for (i = 1; i <= t; ++i)
		{
			scanf("%d%d%d", &from, &to, &cost);
			if (cost < map[from][to])               
				map[from][to] = map[to][from] = cost;
		}
		for (i = 1; i <= n; ++i)
			dis[i] = map[1][i];
		dijkstra(n);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值