Til the Cows Come Home(Dijk)

Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

翻译:

贝西在田里,想在农夫约翰叫醒她早上挤奶之前回到谷仓尽可能多地睡一觉。贝西需要她的美梦,所以她想尽快回来。
农场主约翰的田里有n(2<=n<=1000)个地标,唯一编号为1…n。地标1是谷仓;贝西整天站在其中的苹果树林是地标n。奶牛在田里行走时使用地标间不同长度的T(1<=t<=2000)双向牛道。贝西对自己的导航能力没有信心,所以一旦开始,她总是沿着一条从开始到结束的路线行进。
根据地标之间的轨迹,确定贝西返回谷仓必须走的最小距离。这样的路线一定存在。

input

* Line 1: Two integers: T and N

* Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

翻译:

*第1行:两个整数:t和n
*第2.t+1行:每行将一条轨迹描述为三个空格分隔的整数。前两个整数是两条轨迹之间的标志。第三个整数是轨迹的长度,范围为1…100。

output

Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

*第1行:一个整数,贝西从N地标到1地标所需的最小距离。

sample input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

sample output

90

一个很基础的dijkstra算法求最短路问题,题目大意是求贝西所在地 到谷仓的最短路程。

注意:题目中说明 输入的道路是双向的!

dijkstra算法基本思想:每次找到距离源点最近的一个点,然后再以该顶点为中心进行扩展,同时松弛源点到该顶点扩展点的距离(即比较源点到扩展点的距离与与源点到顶点再到扩展点的距离的大小,取两者中的最小值),最终得到源点到其余所有点的最短路径。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm> 
#include<cstring> 
#define inf 99999999;
int e[1111][1111],dis[1111],book[1111];      //定义    e   是两地标之间的距离     dis  是到 谷仓的距离   book 做标记 
int n,m,a,b,c,i,j,min,v;
void dijk()
{	
    
	for(i=1;i<=n;i++)       //循环 
	{
		min = inf;
		for(j=1;j<=n;j++)
		{
			if(!book[j] && dis[j]<min)      // 求出  没被标记的点中距离谷仓最近的一个 
			{	
			    min=dis[j];
				v=j;
			}
		}
		book[v]=1;          //标记 
		for(j=1;j<=n;j++)
		{
			if(!book[j]&&dis[j]>dis[v]+e[v][j])        //更新各个地标到谷仓的距离
				dis[j]=dis[v]+e[v][j];
		}
	}
 } 
int main()
{
	while(~scanf("%d%d",&m,&n))     //输入  m  条道路    n  个地标 
	{
			for(i=1;i<=n;i++)        //初始化地标间的距离 
			{
				for(j=1;j<=n;j++)
	    {
		    if(i==j)
		    e[i][j]=e[j][i]=0;
		    else
		    e[i][j]=e[j][i]=inf;
	    }
			}

	for(i=1;i<=m;i++)
	{
		scanf("%d%d%d",&a,&b,&c);       //输入两个地标之间的距离 
		if(e[a][b]>c)
		e[a][b]=e[b][a]=c;
	}
	for(i=1;i<=n;i++)           //初始化数组  dis   和    book 
	{
		 dis[i]=e[1][i];
		 book[i]=0;
	}
	book[1]=1;            //标记 谷仓 
	dijk();      //调用 
	printf("%d\n",dis[n]);      //输出 
	}
	return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

努力的小朱同学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值