bfs-非常可乐(倒水输入最少次数题)

非常可乐
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27624 Accepted Submission(s): 10740

Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input
7 4 3
4 1 3
0 0 0

Sample Output
NO
3
个人心得:

ac代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 105;
bool v[4];
bool vis[maxn][maxn][maxn];

struct Node
{
	int v[4];
	int step;
} temp;

void pour(int a, int b)  //倒水函数,把a杯子中的可乐倒到b杯子中
{
	int sum = temp.v[a] + temp.v[b];
	if (sum >= v[b])
		temp.v[b] = v[b];
	else
		temp.v[b] = sum;
	temp.v[a] = sum - temp.v[b];
}

void BFS()
{
	queue<Node>q;
	Node now;
	now.v[0] = v[0];
	now.v[1] = 0;
	now.v[2] = 0;
	now.step = 0;
	q.push(now);
	memset(vis, false, sizeof(vis));
	vis[v[0]][0][0] = true;
	while (!q.empty())
	{
		now = q.front();
		q.pop();
		if (now.v[0] == now.v[2] && now.v[1] == 0)
		{
			cout << now.step << endl;      //步骤输出
			return;
		}
		for (int i = 0; i < 3; i++)
		{
			for (int j = 0; j < 3; j++)
			{
				if (i != j)//自己不倒水给自己
				{
					temp = now;
					//每个水位情况都要把所有操作枚举一遍,
					//所以都要赋值为原始水位情况
					pour(i, j);
					if (!vis[temp.v[0]][temp.v[1]][temp.v[2]])
					{
						temp.step++;
						q.push(temp);
						vis[temp.v[0]][temp.v[1]][temp.v[2]] = true;
					}
				}
			}
		}
	}
	cout << "NO" << endl;
}
int main()
{
	while (scanf("%d%d%d", &v[0], &v[1], &v[2]) != EOF)
	{
		if (v[0] + v[1] + v[2] == 0)
			break;
		if (v[1] > v[2])       //保证v1小于v2
			swap(v[1], v[2]);
		BFS();
	}
	return 0;
}

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值