POJ1840Eqs(哈希表)

Eqs 
Time Limit: 5000MS Memory Limit: 65536K 
Total Submissions: 16763 Accepted: 8223 
Description

Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation. 
Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks. 
Output

The output will contain on the first line the number of the solutions for the given equation. 
Sample Input

37 29 41 43 47 
Sample Output

654 

Source

思路:分成两段循环降低时间复杂度,避免超时。

#include <stdio.h>
#include <string.h>

int hash[25000001];

int main()
{
    int a1,a2,a3,a4,a5,x1,x2,x3,x4,x5,sum;

    while(~scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5))
    {
        memset(hash,0,sizeof(hash));
        for(x1 = -50; x1<=50; x1++)
        {
            if(!x1)
                continue;
            for(x2 = -50; x2<=50; x2++)
            {
                if(!x2)
                {
                    //printf("x2=%d\n",x2);
                    continue;
                }
                sum = -1*(a1*x1*x1*x1+a2*x2*x2*x2);
                if(sum<0)
                    sum+=25000000;//数字下标没有负数,换一种出储存方式
                hash[sum]++;
            }
        }
        int cnt = 0;
        for(x3 = -50; x3<=50; x3++)
        {
            if(!x3)
                continue;
            for(x4 = -50; x4<=50; x4++)
            {
                if(!x4)
                    continue;
                for(x5 = -50; x5<=50; x5++)
                {
                    if(!x5)
                        continue;
                    sum = a3*x3*x3*x3+a4*x4*x4*x4+a5*x5*x5*x5;
                    if(sum<0)
                        sum+=25000000;
                    cnt+=hash[sum];
                }
            }
        }
        printf("%d\n",cnt);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值