poj-1840 Eqs 暴力+哈希

5 篇文章 0 订阅

Description

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

    题意:给你了一个5元3次方程,求解的个数。

    思路:直接暴力枚举是肯定超时的。首先可以将方程变换一下,a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0变为a3x33+ a4x43+ a5x53=-(a1x13+ a2x23)这样100^5的复杂度就变为了100^3+100^2然后将等式左或右的值暴力枚举存入哈希表,由于可能存在负值那么我们让负值+25000000转化为正,并且保证数值的唯一性。再暴力枚举等式另一边,将哈希表对应的值直接存入ans累加器中,最后输出ans得解。注意!!25000000的数组很大,如果用int型会爆内存,short型足够,直接用short定义数组。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#define INF 0x3f3f3f3f
#define mod 1000000007

using namespace std;

short hash[25000000];
int main()
{
    memset(hash,0,sizeof(hash));
    int a1,a2,a3,a4,a5;
    int x1,x2,x3,x4,x5,sum;
    while(scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5)!=EOF)
    {
        int ans=0;
        for (x1=-50;x1<=50;x1++)
        {
            if(!x1) continue;
            for (x2=-50;x2<=50;x2++)
            {
                if(!x2) continue;
                sum=-1*(a1*x1*x1*x1+a2*x2*x2*x2);
                if(sum<0)
                    sum += 25000000;
                    hash[sum]++;
            }
        }
        for (x3=-50;x3<=50;x3++)
        {
            if(!x3) continue;
            for (x4=-50;x4<=50;x4++)
            {
                if(!x4) continue;
                for (x5=-50;x5<=50;x5++)
                {
                    if(!x5) continue;
                    sum = a3*x3*x3*x3+a4*x4*x4*x4+a5*x5*x5*x5;
                    if(sum<0) sum += 25000000;
                    ans += hash[sum];
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值