POJ1125Stockbroker Grapevine(最短路径)

27 篇文章 0 订阅
17 篇文章 0 订阅
Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37273 Accepted: 20737

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10
*题目大意:要求找出谁先知道消息可以使消息让所有人知道且传播最快。输入的第一行N为总人数,接下来N+i行第一个数num为向num个人传递消息,接下来的数据依次表示为第i个人向a传递消息所用的时间t; 输出要求是输出第“ i ”个人最开始知道并传播消息可以使所有人最快知道,以及所用的时间(向其他人的传播可同时开始)。
*解题思路:图的构建是有方向的,所以用Flyod算法,找出两两传播消息的最短时间。图经Flyod算法更新后,每行就表示第i(行)个人向第J(列)个人传递消息的最短时间,因为消息传递可以同时开始,所以只要找出每行中的最大值就表示使所有人知道消息所用的时间,然后再每行中的最大值作比较更新出最小值,即按要求找出了传播最小时间。最后只需要输出i(行)和时间minn即可。如果不能使所有人知道,则输出“disjointed”。
#include<cstdio>
#define INF 99999999
using namespace std;
int map[105][105];
void Flyod(int n)
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(map[i][j]>map[i][k]+map[k][j])
                    map[i][j]=map[i][k]+map[k][j];
            }
        }
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                map[i][j]=INF;
        for(int i=1;i<=n;i++)
        {
            int num;
            scanf("%d",&num);
            for(int j=1;j<=num;j++)
            {
                int a,t;
                scanf("%d %d",&a,&t);
                map[i][a]=t;
            }
        }
        Flyod(n);
        int minn=INF,maxx,cnt;
        for(int i=1;i<=n;i++)
        {
            maxx=0;
            for(int j=1;j<=n;j++)
            {
                if(map[i][j]>maxx&&i!=j)
                    maxx=map[i][j];
            }
            if(minn>maxx)
            {
                minn=maxx;
                cnt=i;
            }
        }
        if(minn<INF)
            printf("%d %d\n",cnt,minn);
        else
            printf("disjoint\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值