POJ 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 98011 Accepted: 30779

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
思路:构图然后广度优先搜索。
#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 100005
int font[2*MAX];//存储所到位置的坐标
int hash[2*MAX];//记录到下标坐标所走的步数(最大位置是100000*2)
int n,k;
int has(int i)
{
    if(i>=2*MAX||i<0||hash[i])
        return 0;//剪枝,对之前判断过的点使程序不再对其作处理
    else return 1;
}
int BFS(int n,int k)
{
    if(n==k)return 0;//牛和农夫处在同一坐标
    int x,first=0,last=0;
    font[first++]=n;
    while(last<first)
    {
        //printf("first=%d last=%d\n",first,last);
        x=font[last++];
        //printf("x=%d hash[%d]=%d\n",x,x,hash[x]);
        if(x-1==k||x+1==k||x*2==k)
            return hash[x]+1;//特殊坐标,一步即可完成
        if(has(x-1)==1)
            hash[x-1]=hash[x]+1,font[first++]=x-1;
        if(has(x+1)==1)
            hash[x+1]=hash[x]+1,font[first++]=x+1;
        if(has(x*2)==1)
            hash[x*2]=hash[x]+1,font[first++]=x*2;
    }//三个if把三种情况都走一遍并做记录。
    return -1;
}
int main()
{
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        memset(hash,0,sizeof(hash));
        int a=BFS(n,k);
        printf("%d\n",a);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值