西安赛区 sum

Define the function S(x)S(x) for xx is a positive integer. S(x)S(x) equals to the sum of all digit of the decimal expression of xx. Please find a positive integer kk that S(k*x)\%233=0S(kx)%233=0.

Input Format

First line an integer TT, indicates the number of test cases (T \le 100T100). Then Each line has a single integer x(1 \le x \le 1000000)x(1x1000000) indicates i-th test case.

Output Format

For each test case, print an integer in a single line indicates the answer. The length of the answer should not exceed 20002000. If there are more than one answer, output anyone is ok.

样例输入
1
1
样例输出
89999999999999999999999999
思路:使k的各位和始终为233,k*x的各位和(乘出来找规律)就为233个x的各个位上的数的和的和。
借鉴的大神的代码:
#include <cstdio>
using namespace std;

int lenght(int n)
{
    int len=0;
    while(n)
    {
        len++;
        n/=10;
    }
    return len;
}

int main()
{
    int T,x,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&x);
        int len=lenght(x);
        printf("1");
        switch(len)
        {
            case 1:
                for(i=1;i<233;i++)
                    printf("1");
                break;
            case 2:
                for(i=1;i<233;i++)
                    printf("01");
                break;
            case 3:
                for(i=1;i<233;i++)
                    printf("001");
                break;
            case 4:
                for(i=1;i<233;i++)
                    printf("0001");
                break;
            case 5:
                for(i=1;i<233;i++)
                    printf("00001");
                break;
             case 6:
                for(i=1;i<233;i++)
                    printf("000001");
                break;
            case 7:
                for(i=1;i<233;i++)
                    printf("0000001");
                break;
        }
        printf("\n");
    }
    return 0;
}


方法二:

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        int i;
        for(i=1;i<=233;i++)
            printf("%d",(int)233/n);
        printf("\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值