SDUT 2137 数据结构实验之求二叉树后序遍历和层次遍历

数据结构实验之求二叉树后序遍历和层次遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。

Example Input
2
abdegcf
dbgeafc
xnliu
lnixu
Example Output
dgebfca
abcdefg
linux
xnuli
Hint
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
typedef struct node
{
    char data;
    struct node *l;
    struct node *r;
}BTnode,*BT;
char pre[55],in[55];
BTnode *Create(char *pre,char *in,int n)
{
    BTnode *b;
    char *p;
    int k;
    if(n<=0) return NULL;
    b=(BTnode *)malloc(sizeof(BTnode));
    b->data=*pre;
    for(p=in;p<in+n;p++)
        if(*p==*pre)
        break;
    k=p-in;
    b->l=Create(pre+1,in,k);
    b->r=Create(pre+k+1,p+1,n-k-1);
    return b;
}
void Postorder(BTnode *root)
{
    if(root!=NULL)
    {
        Postorder(root->l);
        Postorder(root->r);
        printf("%c",root->data);
    }
}
void Levelorder(BTnode *root)
{
    queue<BT> q;
    BT p;
    p=root;
    if(p)
        q.push(p);
    while(!q.empty())
    {
        p=q.front();
        q.pop();
        printf("%c",p->data);
        if(p->l)
            q.push(p->l);
        if(p->r)
            q.push(p->r);
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",pre);
        scanf("%s",in);
        int len=strlen(pre);
        BTnode *root;
        root=Create(pre,in,len);
        Postorder(root);
        printf("\n");
        Levelorder(root);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值