uva 11462 - Age Sort

11462 - Age Sort

You are given the ages (in years) of all people of a country with at least 1 year of age. You know thatno individual in that country lives for 100 or more years. Now, you are given a very simple task of

sorting all the ages in ascending order.

Input

There are multiple test cases in the input le. Each case starts with an integer n (0 < n 2000000), the
total number of people. In the next line, there are n integers indicating the ages. Input is terminated
with a case where n = 0. This case should not be processed.
Output
For each case, print a line with n space separated integers. These integers are the ages of that country
sorted in ascending order.
Warning: Input Data is pretty big ( 25 MB) so use faster IO.
Sample Input
5
3 4 2 1 5
5
2 3 2 3 1
0
Sample Output
1 2 3 4 5

1 2 2 3 3

题意:

给定你一组年龄,要你按从小到大排序。

思路:

用sort()函数进行排序即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=2000000;
int  a[maxn];
int main()
{
    int n;
    while(cin>>n&&n!=0)

    {
        for(int i=0;i<n;i++)
          cin>>a[i];
            sort(a,a+n);
        for(int i=0;i<n-1;i++)
           cout<<a[i]<<' ';
           cout<<a[n-1];
           cout<<endl;

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值