UVA 11877 Description


11877 - The Coco-Cola Store

Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop,

you'll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many
full bottles of coco-cola can you drink?
Input
There will be at most 10 test cases, each containing a single line with an integer n (1 n 100). The
input terminates with n = 0, which should not be processed.
Output
For each test case, print the number of full bottles of coco-cola that you can drink.
Spoiler
Let me tell you how to drink 5 full bottles with 10 empty bottles: get 3 full bottles with 9 empty
bottles, drink them to get 3 empty bottles, and again get a full bottle from them. Now you have 2
empty bottles. Borrow another empty bottle from the shop, then get another full bottle. Drink it, and
nally return this empty bottle to the shop!
Sample Input
3
10
81
0
Sample Output
1
5

40

#include<iostream>
using namespace std;
int main()
{
    int n,sum;
    while(cin>>n&&n!=0)
    {
        sum=0;
        while(n>0)
        {
             sum+=n/3;
            n=n%3+n/3;
            if(n==1)
                break;
            if(n==2)
            {sum+=1;
            break;
            }
        }
       cout<<sum<<endl;

    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值