11877 - The Coco-Cola Store
Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop,
you'll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how manyfull bottles of coco-cola can you drink?
Input
There will be at most 10 test cases, each containing a single line with an integer n (1 n 100). The
input terminates with n = 0, which should not be processed.
Output
For each test case, print the number of full bottles of coco-cola that you can drink.
Spoiler
Let me tell you how to drink 5 full bottles with 10 empty bottles: get 3 full bottles with 9 empty
bottles, drink them to get 3 empty bottles, and again get a full bottle from them. Now you have 2
empty bottles. Borrow another empty bottle from the shop, then get another full bottle. Drink it, and
nally return this empty bottle to the shop!
Sample Input
3
10
81
0
Sample Output
1
5
40
#include<iostream>
using namespace std;
int main()
{
int n,sum;
while(cin>>n&&n!=0)
{
sum=0;
while(n>0)
{
sum+=n/3;
n=n%3+n/3;
if(n==1)
break;
if(n==2)
{sum+=1;
break;
}
}
cout<<sum<<endl;
}
return 0;
}