uva10474

Where is the Marble? 

 Description

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.


Output
For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

`x found at y', if the first marble with number x was found at position y. Positions are numbered 1, 2,..., N.
`x not found', if the marble with number x is not present.
Look at the output for sample input for details.

Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0
Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found

3 found at 3

题意:

输出输入的数字在数组中的位置, 使用强大的STL,排序使用sort()后使用lower_bound()函数;用于查找大于或等于x的第一个位置.
参数为:
lower_bound(数组的开始位置,结束位置,查找的数据)
sort(begin,end),表示一个范围.

使用STL AC代码:


  
  
//这么简单的题目错了好多次,错误越多,更会督促我前行!!

#include<cstdio>
#include<algorithm>
#include<iostream>

using namespace std ;
const int maxn = 10000 ; //错了无数次,忘了加等号,忘了数据类型!!!


int main ()
{
int n , x , q , a [ maxn ], kase = 0 ;
while ( scanf ( "%d%d" , & n , & q ) == 2 && n ) //这里居然掉了取地址符号,wrong了!!
{
for ( int i = 0 ; i < n ; i ++ ) scanf ( "%d" , & a [ i ]);
printf ( "CASE#%d/n" , ++ kase ); //这里要按照题目要求先输出一组,在输出另一组,以此类推。

sort ( a , a + n ); //排序
while ( q -- )
{
scanf ( "%d" , & x );
int p = lower_bound ( a , a + n , x ) - a ; //这里返回的是地址,减掉A之后变为数组下标,千万注意!!
if ( a [ p ] == x ) printf ( "%d found at %d" , x , p );
else printf ( "%d not found" , x );
}

}
return 0 ;
}
老铁们,晚安了,今晚满课,只能做一道了。








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值