uva 673 Parentheses Balance

 

Parentheses Balance

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)if it is the empty string (b)if A and B are correct, AB is correct, (c)if A is correct, (A ) and [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.

Output

A sequence of Yes or No on the output file.

Sample Input

3
([])
(([()])))
([()[]()])()

 Sample Output

Yes
No
Yes


Miguel Revilla
2000-08-14
题意:
如果有一个'('那么就要有一个)与它匹配,如果有一个'['那么就要有一个']'与它匹配.。如果都满足,输出”YES“,else 输出”NO“.
思路;
建立一个栈,左括号’[‘,'('都入栈,右括号')',']'都出栈依次进行下去,如果栈为空,则满足条件,输出“YES”,如果不满足条件,则输出”NO“。
代码:
#include<cstdio>
#include<stack>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
        getchar();
        while(n--)
        {
            char a[130];
            stack<char> s;
            gets(a);
            int flag=0;
    for(int i=0;a[i]!='\0';i++)
        {
            if(a[i]=='('||a[i]=='[')
                 s.push(a[i]);
            else if(a[i]==')')
            {
                if(!s.empty()&&s.top()=='(')   s.pop();
                else
                    {flag=1;break;}
            }
            else if(a[i]==']')
            {
                if(!s.empty()&&s.top()=='[')
                    s.pop();
                else {flag=1;break;}
            }

        }
        if(flag||!s.empty())   printf("No\n");
        else printf("Yes\n");
        }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值