(UVA - 673)Parentheses Balance(括号匹配,栈)

链接:https://vjudge.net/problem/UVA-673
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes

题意:输入一个包含”()”和”[]”的括号字符串,判断是否合法。
规则:1.空串合法
2.如果A和B合法,则AB合法
3.如果A合法则[A]和(A)合法

分析:按照规则用栈来写, 输入的时候要注意 用gets()输入,并且要读掉换行符! scanf输出会WA

#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;
const int N=150+5;
char str[N];
stack<char>st;
bool paired(char ch1,char ch2)
{
    if(ch1=='('&&ch2==')'||ch1=='['&&ch2==']')
        return true;
    return false;
}
bool solve(char *s)
{
    while(!st.empty())
        st.pop();
    int len=strlen(s);
    if(len&1) return false;
    if(len==0) return true;
    for(int i=0;i<len;i++)
    {
        if(!st.empty()&&paired(st.top(),s[i]))
            st.pop();
        else st.push(s[i]);
    }
    return st.empty();
}
int main()
{
    int t;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        gets(str);
        bool ans=solve(str);
        printf("%s\n",ans?"Yes":"No");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值