sdut2411 Pixel density

10 篇文章 0 订阅

Pixel density

Time Limit: 1000MS Memory limit: 65536K

题目描述

 

Pixels per inch (PPI) or pixel density is a measurement of the resolution of devices in various contexts; typically computer displays, image scanners, and digital camera image sensors. Note, the unit is not square inches. Good quality photographs usually require 300 pixels per inch when printed. When the PPI is more than 300(phone), we call it retina screen. Sunnypiggy like the retina screen very much.

 


But you know it is expensive for Sunnypiggy and Sunnypiggy’s own smart phone isn’t like that.
I tell you how to calculate the PPI. First we must know how big the mobile phone’s screen is. Then we get the resolution (Hp*Wp) about it. After that we calculate the diagonal resolution in pixels (Dp) and divided by diagonal size in inches. Now you get the answer.
Maybe you knew it, but Sunnypiggy’s math is very bad and he wants you to help him to calculate the pixel density of all the electronic products he dreamed.
 

输入

First you will get an integer T which means the number of test cases, and then Sunnypiggy will tell you the name and type of the electronic products. And you know, Sunnypiggy is a careless boy and some data aren’t standard, just like 04.00 inches or 0800*0480.

输出

Output the answers to Sunnypiggy just like the sample output. Maybe it is not a phone. Sunnypiggy like such a form, although it seems no use. The result should be rounded to 2 decimal places. When it has no screen (0.0 inches) that we define the answer is 0.00(PPI).

示例输入

2iPhone 4S  3.5 inches 960*640 PHONEThe new iPad  0009.7 inches 2048*1536 PAD

示例输出

Case 1: The phone of iPhone 4S's PPI is 329.65.Case 2: The pad of The new iPad's PPI is 263.92.

提示

来源

2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛

示例程序





/***
坑很多,
1.inches的值可能为0,那样就不能除了
2.把大写变小写的话,需要判断它确实为大写
3.反正是字符串的处理小心点就行了
***///
#include<cstring>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<string.h>
#include<stdio.h>
using namespace std;
int main()
{
    int t,kase=0;
    cin>>t;

    while(t--)
    {
        getchar();
        char c,s[100][50];
        int k=0;
        while(1)
        {
            cin>>s[k];
            if( strcmp(s[k],"inches")==0 )
                break;
            k++;
        }
        double inches;
        sscanf(s[k-1],"%lf",&inches);
//        printf("inches==%lf\n",inches);
        getchar();
        double Wp,Hp;
        scanf("%lf*%lf",&Wp,&Hp);
        char str[100];
        scanf("%s",str);
        printf("Case %d: The ",++kase);
        for(int i=0;i<strlen(str);i++)
        {
            if(str[i]>='A' && str[i]<='Z')
                printf("%c",str[i]+32);
            else printf("%c",str[i]);
        }
        printf(" of");
        for(int i=0;i<k-1;i++)
            cout<<" " <<s[i];
        printf("'s PPI is ");
        if(inches == 0) printf("0.00.\n");
         else printf("%.2lf.\n",  sqrt(Wp*Wp+Hp*Hp ) / inches );

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值