HDU4252 A Famous City

19 篇文章 0 订阅
H - 1008
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows: 
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building, or no buildings at all. 
- measure the height of each building in that piece. 
- write a program to calculate the minimum number of buildings. 
Mr. B has finished the first two steps, the last comes to you.
 

Input

Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the input numbers will be nonnegative and less than 1,000,000,000. 
 

Output

For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 

Sample Input

     
     
3 1 2 3 3 1 2 1
 

Sample Output

     
     
Case 1: 3 Case 2: 2

Hint

 The possible configurations of the samples are illustrated below: 
          
    
    
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
int a[100005];
using namespace std;
int main()
{
    int n,kase=0;
    while(scanf("%d",&n)!=EOF)
    {
        int ans=n,k=0;
//        printf("ans==%d\n",ans);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            if(a[i] == 0) { ans--; k=i; }
            else {
                for(int j=i-1;j>=k;j--){

                    if(a[i] > a[j]) break;
                    if(a[i] == a[j]) { ans--; break; }
                }
            }
        }
        printf("Case %d: ",++kase);
        printf("%d\n",ans);

    }
    return 0;
}

这题比较坑,开始做,感觉挺简单的就是不对,后来试数找到了BUG,加了个条件就行了。
就是小的建筑物会把高的建筑物分割,这样两个高的建筑物就不能是一个了,必须是两个建筑物了。
所以要加上
if(a[i] > a[j]) break;
这样,循环到比自己小的建筑物上,就不用往后走了,省了时间
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值