A1023. Have Fun with Numbers (20)

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

	#include<cstdio>
	#include<cstring>
	#include<algorithm>
	using namespace std;
	int main(){
		bool flag = 1;		//表示符合要求
		int hashTable[256] = {0};
		char str1[22],str2[22];
		scanf("%s",str1);
		int len1 = strlen(str1);
		int len2 = len1;		//len2必须通过len1来求,否则会输出额外的东西?
		reverse(str1,str1+len1);		//反转字符串
		for(int i = 0;i < len1;i++)
			hashTable[str1[i]]++;
		int carry = 0;
		for(int i = 0;i < len1;i++){
			str2[i] = ((str1[i]-'0')*2+carry)%10+'0';
			carry = ((str1[i]-'0')*2+carry)/10;
		}
		if(carry){ 
			flag = 0;
			len2++;
			str2[len1] = carry+'0';
		}
		else {
			for(int i = 0;i < len1;i++)
				hashTable[str2[i]]--;
			for(int i = 0;i < len1;i++)
				if(hashTable[str2[i]]) flag = 0;
		}
		if(flag) printf("Yes\n");
		else printf("No\n");
		for(int i = len2-1;i >= 0;i--)
			printf("%c",str2[i]);
		printf("\n");
		return 0;
	}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值