PAT - 甲级 - 1023. Have Fun with Numbers (20)(大整数)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

给定条件:
1.给定一个不超过20位的数字,只有1-9十个数字

要求:
1.将这个数字乘以2
2.得到的新的数字是否和原来的给定的数包含的数字都是相同的,并且每个数字出现的次数也都是相同的

求解:
1.记录每个数字出现的次数
2.用数组模拟乘法运算的到结果
3.遍历得到的新数字,进行判断


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
int num[25], book[25];
char input[25];
int main() {
	fill(book, book+25, 0);
	
	scanf("%s", input);
	n = strlen(input)-1;

	for(int i = n; i >= 0; i--) {
		num[n-i] = input[i] - '0';
		book[num[n-i]]++;
	}

	int up = 0;
	for(int i = 0; i <= n; i++) {
		int sum = 2 * num[i] + up;
		num[i] = sum % 10;
		up = sum / 10;
	}
	if(up != 0){
		num[++n] = up;
	}

	int flag = 1;
	for(int i = 0; i <= n; i++) {
		book[num[i]]--;
		if(book[num[i]] < 0){
			printf("No\n");
			flag = 0;
			break;
		}
	}

	if(flag) printf("Yes\n");
	for(int i = n; i >= 0 ; i--) {
		printf("%d", num[i]);
	}
	printf("\n");

	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值