1010. Radix (25)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:6 110 1 10Sample Output 1:
2Sample Input 2:
1 ab 1 2Sample Output 2:
Impossible
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll inf = (1LL<<63)-1; //这个地方用vim + g++ 无法编译
ll Map[256];
void init(){
for(char c = '0';c <= '9';c++)
Map[c] = c -'0';
for(char c = 'a';c <= 'z';c++)
Map[c] = c - 'a' + 10;
}
ll trans(char str[],ll radix,ll t){
ll sum = 0;
int len = strlen(str);
for(int i = 0;i < len;i++){
sum = sum*radix + Map[str[i]];
if(sum<0 || sum > t) return -1; //溢出或超出N1直接返回
}
return sum;
}
ll findMaxDigit(char str[]){
int len = strlen(str);
ll low = -1;
for(int i = 0;i < len;i++)
if(Map[str[i]]>low)
low = Map[str[i]];
return low+1;
}
int cmp(char str[],ll radix,ll n1){
ll n2 = trans(str,radix,n1);
if(n2 < 0) return 1;
else if(n2<n1) return -1;
else if(n2==n1) return 0;
else return 1;
}
ll binarySearch(ll low,ll high,char str[],ll n1){
ll mid;
while(low<=high){
mid = (low+high)/2;
int flag = cmp(str,mid,n1);
if(flag == -1) low = mid+1;
else if(flag == 1) high = mid-1;
else return mid;
}
return -1;
}
int main(){
init(); //不要忘记初始化!
char str1[11],str2[11];
long long tag,radix;
scanf("%s %s %lld %lld",str1,str2,&tag,&radix);
if(tag==2){
char temp[11];
strcpy(temp,str1);
strcpy(str1,str2);
strcpy(str2,temp);
}
ll n1 = trans(str1,radix,inf); //得出N1
ll low = findMaxDigit(str2); //二分下界
ll high = max(low,n1)+1; //上界
ll r = binarySearch(low,high,str2,n1);
if(r!=-1)
printf("%lld\n",r);
else
printf("Impossible\n");
return 0;
}