1105. Spiral Matrix (25) 排序、模拟

1105.Spiral Matrix (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
更新一个更好的方法。
首先要求出矩阵的行和列,行要大于等于列。
对数组进行排序。
建立一个矩阵数组,用于储存矩阵结果。
设四个变量minR,maxR,minC,maxC,用于记录当前需要填充的行列的边界。
填充方法按题目所述,设置当前行列,nowR,nowC,从左至右,从上到下,从右到左,从下到上进行填充。并更新行列边界值。

//
// Created by aleafall on 16-12-3.
//

#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int main(){
    int N, m, n;
    cin >> N;
    int a[N + 1];
    for (int i = 0; i < N; ++i) {
        scanf("%d", &a[i]);
    }
    sort(a, a + N);
    m = (int) sqrt(1.0 * N);
    while (N%m) {
        ++m;
    }
    n = N / m;
    if (n > m) {
        swap(m, n);
    }
    int num[m + 1][n + 1];
    int index = N - 1;
    int minR = 0, maxR = m - 1, minC = 0, maxC = n - 1;
    while (index >= 0) {
        for (int nowC = minC,nowR=minR; nowC <=maxC ; ++nowC) {
            num[nowR][nowC] = a[index--];
        }
        ++minR;
        for (int nowR = minR,nowC=maxC; nowR <=maxR ; ++nowR) {
            num[nowR][nowC] = a[index--];
        }
        --maxC;
        if (index < 0) {    //数据可能已经完成了填充
            break;
        }
        for (int nowC = maxC,nowR=maxR; nowC >=minC ; --nowC) {
            num[nowR][nowC] = a[index--];
        }
        --maxR;
        for (int nowR = maxR,nowC=minC; nowR >=minR ; --nowR) {
            num[nowR][nowC] = a[index--];
        }
        ++minC;
    }
    for (int i = 0; i < m; ++i) {
        for (int j = 0; j < n; ++j) {
            if (j < n - 1) {
                printf("%d ", num[i][j]);
            } else {
                printf("%d\n", num[i][j]);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值