1110. Complete Binary Tree (25) 完全二叉树、树的遍历

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line “YES” and the index of the last node if the tree is a complete binary tree, or “NO” and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1

更新,
首先建立二叉树,然后根据完全二叉树(完全二叉树_百度百科)的性质,即将CBT的结点编号为1~n的话,则父结点p的左右孩子编号分别为p*2, p*2+1。使用二叉树的先序遍历,给根节点传递索引为1,其左右孩子索引为2*1和2*1+1,以此类推,记录最大的索引,如果最大索引为n,则为CBT。可由
根节点不是任何结点的子结点来确定。

//
// Created by aleafall on 16-12-4.
//

#include <iostream>

using namespace std;

const int maxn = 21;

struct Node {
    int left = -1, right = -1;
} node[maxn];

int max_index = 0, last = 0;

void preOrder(int v, int index) {
    if (v == -1) {
        return;
    }
    if (index > max_index) {
        max_index = index;
        last = v;
    }
    preOrder(node[v].left, 2 * index);
    preOrder(node[v].right, 2 * index + 1);
}

int main() {
    int n, x, root = 0;
    bool vis[maxn] = {0};
    string s1, s2;
    cin >> n;
    for (int i = 0; i < n; ++i) {
        cin >> s1 >> s2;
        if (s1 != "-") {
            x = atoi(s1.c_str());
            node[i].left = x;
            vis[x] = 1;
        }
        if (s2 != "-") {
            x = atoi(s2.c_str());
            node[i].right = x;
            vis[x] = 1;
        }
    }
    for (int i = 0; i < n; ++i) {
        if (vis[i] == 0) {
            root = i;
            break;
        }
    }
    preOrder(root, 1);
    if (max_index == n) {
        cout << "YES " << last << endl;
    } else {
        cout << "NO " << root << endl;
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值