poj1836(dp)

是个水题,最长上升子序列。。。
读题把自己给坑了,唉,英文有点弱啊,发个blog来记住这个尴尬的题吧。。

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

 

4


#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
int main()
{
    int dp[1001];
    int b[1001];
    double a[1001];
    int n,i,j,low,on;
    fill(dp,dp+1000,1);
    fill(b,b+1000,1);
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%lf",&a[i]);
    }
    if(n<=2)
    {
        printf("0\n");
    }
    else
    {
        low=on=-1;
        for(i=0;i<n;i++)
        {
            for(j=0;j<i;j++)
            {
                if(a[i]>a[j])
                {
                    dp[i]=max(dp[i],dp[j]+1);
                }
            }
        }
        for(i=n-1;i>=0;i--)
        {
            for(j=n-1;j>i;j--)
            {
                if(a[i]>a[j])
                {
                    b[i]=max(b[i],b[j]+1);
                }
            }
        }
        int res=-1;
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                res=max(res,dp[i]+b[j]);
            }
        }
        printf("%d\n",n-res);
    }
    return 0;
}
好好读题啊,以后!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值