Python3 PyQt5 pycharm 环境搭建

原文链接

简书的 markdown 没有目录,截图一张,让大家看的清楚,找到自己需要的东西。


image.png

开发环境:

MAC OS 10.12.3 版本 (当前最新)
Pycharm 2016.3.2 版本 (当前最新)
Python 3.6.0 版本 (当前最新)
PyQt5 5.8.1 版本 (当前最新)
pyinstaller:将python代码打包为可执行的exe文件。

exe文件给Windows用,但是本章不安装,但是不排除后期更新文章,因为博主还没入门,还没考虑这么多!!!“囧”)

为什么写这篇博客?

尼玛是资料太少(几乎没有完整的),花了1整天时间来配置,不希望大家也浪费,时间是金钱买不来的

需要安装哪些东西呢?

  • sip
  • PyQt5
  • Qt
  • python

python不会安装的可以参考Python版本管理:pyenv和pyenv-virtualenv

Pycharm 安装自行百度,很简单,一路点击下一步

sip


意思是说:
在从源代码构建PyQt5之前,您必须已经构建并安装了SIP,就是说你必须要安装这个东西,那么这个东西是什么呢?

什么是sip?

sip是RiverBank(也就是PyQt的开发商)开发的用于PyQt的Python/C++混合编程解决方案。由于Qt框架的复杂性,PyQt并没有使用Cython、SWIG的混合编程方案,而是自己单独做了一套框架。sip包括一个sip工具、SDK和Python Module。

与SWIG类似,使用sip也需要先编写一个『配置文件』,然后使用sip工具『编译』为C++源文件,最后,和Qt库一起编译形成适用于Python的PyQt。

与SWIG不同的是,sip同时以Python Module的形式存在,也就是说,作为Python Module的PyQt,依赖于作为Python Module的sip。而对于SWIG,一旦自动生成的C++生成完毕,整个流程就不再依赖SWIG了。

需要注意:

如果你安装了PyQt4和PyQt5,那么PyQt4和PyQt5无法共享sip。
就像 Python2 和 Python3 严格说不能共享pip 一样,因为有差异,解决方案就是给每个目录配置独立的Python环境(virtualenv),可以参考Python版本管理:pyenv和pyenv-virtualenv

安装sip

方式一:pip安装

使用支持的Python版本,你可以从PyPi安装SIP 通过运行:

pip3 install SIP

喜欢动手的可以试试下面的方式四,目前网上找到的教程都用自己编译的方式。
如果是mac可以用户使用方式三,也很简单,但是python 的环境就不容易隔离开了,不建议。


方式二:pycharm安装

考虑懒癌患者,可以使用pycharm




方式三:使用Homebrew
brew install sip

不知道brew 的自行百度哈。


方式四:手动编译安装

选择这种方式的都是大神。

阅读更多

没有更多推荐了,返回首页