HDOJ 1517 A Multiplication Game

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4723    Accepted Submission(s): 2684


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
 
/*
 * 题意:Stan和Ollie玩游戏,Stan先开始用1乘以2-9之内的数,Ollie再用Stan得到的结果乘以2-9
 * 看谁先得到的数>=n谁就是赢家
 * 思路:如果2<=n<=9 Stan必定赢
 * 如果9<n<=18 Ollie必定赢
 * 以此类推,可以看出谁赢谁输是由规律的
 * 如果n>18的时候我们不断n/=18
 * 再判断最后的n的值就可以了
 * 如果n<=9 Stan赢否则Ollie赢
*/
import java.util.*;  

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        double n;
        while (sc.hasNext()){
            n = sc.nextDouble();
            while (n > 18){
                n /= 18;
            }
            if (n <= 9)
                System.out.println("Stan wins.");
            else
                System.out.println("Ollie wins.");
        }
        
    }

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值