HDOJ 1517 A Multiplication Game

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1517


A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5267    Accepted Submission(s): 2994


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
 

Source


题目大意:
Stan和Ollie玩游戏,两人轮流,首先Stan开始把1乘以一个2到9之间的整数,接着Ollie再将前一个数乘以一个2到9之间的整数。最先使这个数不小于n的人获胜。

解题思路:
NP博弈问题。
P为必败态,N为必胜态。
首先将终态设为P态。
所有能到P态的状态都为N态,只能到N态的状态为P态。

所以[n, +∞)为P态,[ceil(n / 9), n - 1]为N态,[ceill(ceil(n / 9) / 2), ceil(n / 9) - 1]为P态,以此类推。
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    long long n, begin;
    bool flag;

    while(scanf("%I64d", &n) != EOF)
    {
        if(n % 9 == 0) begin = n / 9; else begin = n / 9 + 1;
        flag = true;
        while(begin > 1){
            if(flag){if(begin % 2 == 0) begin = begin / 2; else begin = begin / 2 + 1;}else{if(begin % 9 == 0) begin = begin / 9; else begin = begin/ 9 + 1;}
            flag = !flag;
        }
        if(flag) printf("Stan wins.\n"); else printf("Ollie wins.\n");
    }
    return 0;
}

不难发现其实N、P态有一定规律,可以直接对n一直整除18直到n <= 18,此时n <= 9则Stan wins.
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    double n; //注意是double不是long long

    while(scanf("%lf", &n) != EOF){
        while(n > 18) n /= 18;
        if(n <= 9) printf("Stan wins.\n"); else printf("Ollie wins.\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值