POJ 3279 Fliptile 开关问题

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6541 Accepted: 2487

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0


题意:

农夫约翰知道聪明的牛产奶多。于是为了提高牛的智商他准备了如下游戏。有一个M * N的格子,每个格子可以翻转正反面,他们一面是黑色,另一面是白色。游戏要做的就是把所有的格子都翻转成白色。不过因为牛蹄子很大,所以没翻转一个格子时,与它上下左右相邻接的格子也会被翻转。因为翻格子太麻烦了,所有牛想通过尽可能少的次数把所有格子都翻转成白色。现在给定了每个格子的颜色,请求出用最小步数完成时每个格子的翻转次数。最小步数的解有多个时,输出字典序最小的一组。解不存在的话,输出IMPOSSIBLE。

分析:

先指定好最上面一行的翻转方式,然后可以很容易判断这样是否存在解以及解的最小步数是多少,这样将第一行所有的翻转方式都尝试一次就能求出整个问题的最小步数。

//开关问题
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 15 + 5;

int M, N;
int tile[maxn][maxn];

int opt[maxn][maxn];   //保存最优解
int flip[maxn][maxn];   //保存中间结果

//邻接的格子的坐标
int dx[5] = {-1, 0, 0, 0, 1};
int dy[5] = {0, -1, 0, 1, 0};

//查询(x, y)的颜色
int get(int x, int y)
{
    int c = tile[x][y];
    for (int d = 0; d < 5; d++){
        int x2 = x + dx[d], y2 = y + dy[d];
        if (0 <= x2 && x2 < M && 0 <= y2 && y2 < N){
            c +=flip[x2][y2];
        }
    }
    return c % 2;
}

//求出第一行确定情况下的最小操作数
//不存在解的话返回-1
int calc()
{
    //求出从第2行开始的翻转方法
    for (int i = 1; i < M; i++){
        for (int j = 0; j < N; j++){
            if (get(i - 1, j) != 0){
                //(i - 1, j)是黑色的话,则必须翻转这个格子
                flip[i][j] = 1;
            }
        }
    }

    //判断最后一行是否全白
    for (int j = 0; j < N; j++){
        if (get(M - 1, j) != 0){
            //无解
            return -1;
        }
    }

    //统计翻转的次数
    int res = 0;
    for (int i = 0; i < M; i++){
        for (int j = 0; j < N; j++){
            res += flip[i][j];
        }
    }
    return res;
}

void solve()
{
    int res = -1;

    //按照字典序尝试第一行的所有可能性
    for (int i = 0; i < 1 << N; i++){
        memset(flip, 0, sizeof(flip));
        for (int j = 0; j < N; j++){
            flip[0][N - j - 1] = i >> j & 1;
        }
        int num = calc();
        if (num >= 0 && (res < 0 || res > num)){
            res = num;
            memcpy(opt, flip, sizeof(flip));   //内存拷贝函数
        }
    }

    if (res < 0){
        //无解
        printf("IMPOSSIBLE\n");
    }
    else{
        for (int i = 0; i < M; i++){
            for (int j = 0; j < N; j++){
                printf("%d%c", opt[i][j], j + 1 == N ? '\n' : ' ');
            }
        }
    }
}

int main()
{
    while (scanf("%d%d", &M, &N) != EOF){
        for (int i = 0; i < M; i++){
            for (int j = 0; j < N; j++){
                scanf("%d", &tile[i][j]);
            }
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值