POJ 3630 Phone List (字典树)

Phone List
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27078 Accepted: 8146

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题意:

给出几组电话号码,在某一组号码中,如果存在某一号码为其他号码的前缀,则输出NO,否则输出YES。

分析:

方法一:对每组中的电话号码进行排序,然后再从最短的电话开始与后面的电话号码进行比较,判断当前的电话号码是否是其他某些号码的前缀,直到该组结尾。当问题的规模较大时,这种方法的时间复杂度相对较高,然而空间复杂度则较低。

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;

int main()
{
    int t, n;
    string str[10010];
    string temp;
    int len;
    bool flag;
    cin >> t;
    while (t--){
        cin >> n;
        flag = 1;
        for (int i = 0; i < n; i++)
            cin >> str[i];
        sort(str, str + n);
        for (int i = 0; i < n - 1; i++){
            len = str[i].length();
            temp = str[i + 1].substr(0, len);    //截取字符串
            if (temp == str[i]){
                flag = 0;
                break;
            }
        }
        if (flag)
            cout << "YES" << endl;
        else
            cout << "NO" << endl;
    }
    return 0;
}


方法二:采用字典树实现对每组号码的存储,再逐一对组中的号码进行判断。这种方法空间复杂度较高,但是时间复杂度则很低。

另外如果每次插入号码时都new一个新的字典树结点,程序提交的结果是TLE。因此建立静态结点缓存,每次从缓存中取结点,插入字典树中。

#include <cstdio>
using namespace std;

struct Trie
{
	int count;
	struct Trie *branch[10];
}Memory[70000]; //建立70000个静态结点,一定要把静态开到 1 << 16,不然会RE

int num = 0;

Trie *TrieNode()
{
	Trie *p = &Memory[num++];
	p->count = 0;
	for(int k = 0; k < 10; k++)
	{
		p->branch[k] = NULL;
	}
	return p;
}

//将字符串number插入根为root的字典树
void MakeTrie(Trie *&root, char *number)
{
	int i = 0;
	if(root == NULL)
	{
		root = TrieNode();
	}
	Trie *p = root;
	while(number[i])
	{
		if(!p->branch[number[i] - '0'])
		{
			p->branch[number[i] - '0'] = TrieNode();

		}
		p = p->branch[number[i] - '0'];
		p->count++;
		i++;
	}
}

//判断字符串number是否为其他某字符串的前缀
//如果是返回true,否则返回false
bool IsPrefix(Trie *root, char *number)
{
	int i = 0;
	if(root == NULL)
	{
		return true;
	}
        Trie *p = root;
	while(number[i])
	{
                p = p->branch[number[i] - '0'];
		if(p->count == 1)
			return false;
		i++;
        }

	return true;
}

int main()
{
	bool flag = true;
	int j, n, t;
	Trie *root = NULL;
	char numbers[70000][11];
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d", &n);
		root = NULL;
		for(j = 0; j < n; j++)
		{
			scanf("%s", numbers[j]);
			MakeTrie(root, numbers[j]);
		}

		for(j = 0; j < n; j++)
		{
			if(IsPrefix(root, numbers[j]))
			{
				flag = false;
				break;
			}
		}
		if(flag)
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
		flag = true;
		num = 0;
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值