HDU2114 Calculate S(n) (取模算术)

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9102    Accepted Submission(s): 3325


Problem Description
Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .
 

 

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

 

Output
For each case, output the last four dights of S(N) in one line.
 

 

Sample Input
1 2
 

 

Sample Output
0001 0009
 

 

Author
天邪
方法一:全算出来。
思路:当n>10000以后,只用关心后四位的数字即可。
知识点:模算术公式:(a+b)%n = ((a%n)+(b%n))%n
          (a-b)%n = ((a%n)-(b%n))%n
            a*b%n = (a%n)*(b%n)%n
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
using namespace std;

const int INF=0x3f3f3f3f;
const double eps=1e-10;
const double PI=acos(-1.0);
#define maxn 10005
long long a[maxn];
int main()
{
    long long sum = 0;
    for(int i = 1; i <= 10000; i++)
    {
        sum += (i%10000*i%10000*i%10000)%10000;
        sum  = sum %10000;
        a[i] = sum;
    }
    int n;
    while(~scanf("%d", &n))
    {
        if(n <= 10000)
        {
            printf("%04d\n",a[n]);
        }
        else
        {
            int t = n/10000;
            int k = n - t*10000;
            long long sum1 = 0;
            sum1 = ((t%10000)*(a[10000]%10000))%10000 + a[k]%10000;
            printf("%04d\n",sum1);

        }
    }
    return 0;
}

方法二:直接公式

#include <stdio.h>
int main()
{
    __int64 n,sum;
    while (scanf("%I64d",&n)!=EOF)
    {
        sum=0;
        n=n%10000;
        sum=(n*(n+1)/2)*(n*(n+1)/2)%10000;// 为了防止计算sum中乘法溢出将n=n%10000;因为要求得后4位数。
        printf("%04I64d\n",sum);
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/ZP-Better/p/4639624.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值