HDU--2114

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8905    Accepted Submission(s): 3257


Problem Description
Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .
 

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

Output
For each case, output the last four dights of S(N) in one line.
 

Sample Input
 
  
1 2
 

Sample Output
 
  
0001 0009
 

Author
天邪

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
	long long int n;
	while (cin >> n)
	{
		long long int result;
		result = ((n * (n+1) / 2) %10000) * ((n * (n+1) /2) %10000) %10000;
		printf("%04lld\n",result);
	}
	return 0;
}


转载于:https://www.cnblogs.com/Tovi/p/6194892.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值