hdu2114

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5512    Accepted Submission(s): 2057


Problem Description
Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .
 

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

Output
For each case, output the last four dights of S(N) in one line.
 

Sample Input
  
  
1 2
 

Sample Output
  
  
0001 0009 开始还以为是找规律的 搞了半天没找到循环节 后来一看是套公式的

1^3 + 2^3 + …… n^3 = [n (n+1) / 2]^2=(1+2+……+n)^2

#include<stdio.h>
int main()
{
     __int64 s;
     int n;
     while(scanf("%d",&n)!=EOF)
     {
           n%=10000;//这块注意要取模缩小 否则int64也够呛
           s=n*(n+1)/2%10000;
           s=s*s%10000;
           printf("%04I64d\n",s);
     }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值