算典03_例题_03_HDU-1318

原题

Palindromes

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string “ABCDEDCBA” is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string “3AIAE” is a mirrored string because “A” and “I” are their own reverses, and “3” and “E” are each others’ reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string “ATOYOTA” is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, “A”, “T”, “O”, and “Y” are all their own reverses.

A list of all valid characters and their reverses is as follows.

Character Reverse Character Reverse Character Reverse

A         A         M         M         Y         Y

B                   N                   Z         5

C                   O         O         1         1

D                   P                   2         S

E         3         Q                   3         E

F                   R                   4

G                   S         2         5         Z

H         H         T         T         6

I         I         U         U         7

J         L         V         V         8         8

K                   W         W         9

L         J         X         X

Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter “0” is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

” – is not a palindrome.”
if the string is not a palindrome and is not a mirrored string

” – is a regular palindrome.”
if the string is a palindrome and is not a mirrored string

” – is a mirrored string.”
if the string is not a palindrome and is a mirrored string

” – is a mirrored palindrome.”
if the string is a palindrome and is a mirrored string

Note that the output line is to include the -’s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA

Sample Output

NOTAPALINDROME – is not a palindrome.

ISAPALINILAPASI – is a regular palindrome.

2A3MEAS – is a mirrored string.

ATOYOTA – is a mirrored palindrome.

题解

判断一个字符串是否为回文串和镜像串
回文串的意思就不用说了,正着反着相等就行了
镜像串就是根据上面给出的表格将原串转换过去,得到的新的字符串如果和原串是逆过来相等的,它就是镜像串
这里我觉得对应关系有很多,使用常量数组即可使其对应起来
结果也保存在常量数组里,方便输出

#include <cctype>
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1e4;

char arr[maxn] = { "01SE Z  8 A   3  HIL JM O   2TUVWXY5" };
char ot[4][30] = { " -- is not a palindrome.", " -- is a regular palindrome.", " -- is a mirrored string.", " -- is a mirrored palindrome." };
//                          0 0                             0 1                         1 0                             1 1

char s[maxn];

char find(int id){
    if (isdigit(s[id])){
        return arr[s[id] - '0'];
    }
    else {
        return arr[s[id] - 'A' + 10];
    }
}

int main(){

    while (scanf("%s", s) != EOF) {
        printf("%s", s);
        int p = 1, q = 1, len = strlen(s);

        for (int i = 0; i < len / 2 + 1; ++i) {
            if (p && s[i] != s[len - 1 - i]) p = 0;
            if (q && s[i] != find(len - 1 - i)) q = 0;
        }

        printf("%s\n\n", ot[p + 2*q]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值