uva 401 Palindromes


http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=6&page=show_problem&problem=342

  Palindromes 

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E"are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A""T""O", and "Y"are all their own reverses.


A list of all valid characters and their reverses is as follows.


CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.



Miguel Revilla 2001-04-16

本题很容易看懂懂,条件有点恶心,请注意在判断的回文串的时候,注意区分字母‘O’与数字‘0’的等价关系,在处理时,先把‘0’转化成‘O'!而在判断是否mirrored string的时候,把情况分成两类转化,数字,与字母!最后注意每个样例后面有换行!!
以后是AC代码:
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cctype>
using namespace std;
char character[]="A   3  HIL JM O   2TUVWXY5";
char digits[]="1SE Z  8 ";
int palindrome(char str[])
{
     int i , len;
     len = strlen(str);
     for(i = 0;i < len;i++)
                     if(str[i]!=str[len-i-1])return 0;
     return 1;
}
int mirror(char str[])
{
    int i , len;
    len = strlen(str);
    for(i = 0;i < len; i++)
    {
        
        if(isalpha(str[i])&&str[len - 1 - i]!=character[str[i]-'A'])
           return 0;
        if(isdigit(str[i])&&str[len - 1 - i]!=digits[str[i]-'1'])
           return 0;
    }
      return 1;
}
int main()
{
     int i ,flag1,flag2;
     char str[100];
     while((fgets(str,100,stdin) != NULL))
     {
          str[strlen(str) - 1] = 0;//注意把换行去掉。
          for(i=0;i< strlen(str);i++)
                                  if(str[i]=='0')str[i]='O';
          flag1 = palindrome(str);
          flag2 = mirror(str);  
          if(flag1&&flag2)
          {
                            printf("%s -- is a mirrored palindrome.\n",str);
                            printf("\n");
                            continue;
          }
          if(flag2)
          {
                    printf("%s -- is a mirrored string.\n",str);
                    printf("\n");
                    continue;
          }
          if(flag1)
          {
                    printf("%s -- is a regular palindrome.\n",str);
                    printf("\n");
                    continue;
          }
          
          printf("%s -- is not a palindrome.\n",str);
          printf("\n");
     }
     return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值