HDU 3836

3 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3836

Equivalent Sets

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 2846    Accepted Submission(s): 986


Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
 

Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
 

Output
For each case, output a single integer: the minimum steps needed.
 

Sample Input
  
  
4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
Hint
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.
 

Source
 

  最近复习了一下tarjan,敲了几到题。

题意:说集合之间的相等关系,若集合A=集合B,则A,B互为子集,要求加多少个关系能得到n个集合都相等。

解法:很明显利用tarjan缩点,设有ans1个节点入度为0,ans2个节点出度为0,则max(ans1,ans2)就是答案。需要注意的是若只有一个强连通分量则答案为零,需要特判。

/*************************************************************************
	> File Name: HDU/3836.cpp
	> Author: magicyang
	> Mail:273868471@qq.com
	> Created Time: 2014年09月01日 星期一 18时58分46秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
const int maxn=20005;
vector<int>g[20005];
stack<int>s;
int pre[maxn],lowlink[maxn],scc[maxn],dfs_clk,scc_cnt;
void dfs(int u)
{
    pre[u]=lowlink[u]=++dfs_clk;
    s.push(u);
    for(int i=0;i<g[u].size();i++)
    {
        int v=g[u][i];
        if(!pre[v])
        {
            dfs(v);
            lowlink[u]=min(lowlink[u],lowlink[v]);
        }
        else if(!scc[v])
        {
            lowlink[u]=min(lowlink[u],pre[v]);
        }
    }
    if(lowlink[u]==pre[u])
    {
        scc_cnt++;
        for(;;)
        {
            int x=s.top();s.pop();
            scc[x]=scc_cnt;
            if(x==u) break;
        }
    }
}
void find(int n)
{
    while(!s.empty()) s.pop();
    dfs_clk=scc_cnt=0;
    memset(pre,0,sizeof pre);
    memset(scc,0,sizeof scc);
    for(int i=1;i<=n;i++)
    {
        if(!pre[i])
            dfs(i);
    }
    return ;
}
int in[maxn],out[maxn];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        for(int i=1;i<=n;i++)
            g[i].clear();
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            g[x].push_back(y);
        }
        find(n);
        for(int i=1;i<=scc_cnt;i++)
            in[i]=out[i]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<g[i].size();j++)
            {
                int v=g[i][j];
                if(scc[i]!=scc[v]) out[scc[i]]=in[scc[v]]=0;
            }
        }
        int ans1=0,ans2=0;
        for(int i=1;i<=scc_cnt;i++)
        {
            if(in[i]) ans1++;
            if(out[i]) ans2++;
        }
        int ans=max(ans1,ans2);
        if(scc_cnt==1) cout<<"0"<<endl;
        else cout<<ans<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值