poj 1035 Spell checker

点击打开链接

Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16970 Accepted: 6223

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

题目大意就是, 先给你n个单词,以#结束,作为词典,后面又是m个单词,每个单词输出对应的检查结果,如果正好有这个单词,那么就输出%s is correct,如果没有这个单词,就输出相近的,相近的规则有3个:

1、添加一个字母可以得到的单词

2.、删除一个字母可以得到的单词

3、替换一个字母可以得到的单词

模拟法就可以了,首相只有长度差1的才进行比较,一开始用下标索引一个一个的比较,如果出现一个不一样的,那么有3种情况:

假设在i位置两个字符串不相同。两个字符串为str1和str2

1、比较 str1[i] 和 str2[i + 1]以后的是否相同

2、比较str1[i + 1] 和 str2[i]以后的是否相同

3、比较str1[i + 1] 和 str2[i + 1]以后的是否相同

以上3个条件只要有一个满足,就是相近的单词

#include<stdio.h>
#include<vector>
#include<string>
#include<string.h>
using namespace std;
vector<string > v;
int mycmp(const char *str1, const char * str2)
{
	int len_str1 = strlen(str1);
	int len_str2 = strlen(str2);
	if(len_str1 - len_str2 > 1 || len_str1 - len_str2 < -1)
		return -1;
	int i;
	for(i = 0; i < len_str1 || i < len_str2 ; i++)
	{
		if(i == len_str1 || i == len_str2)
			return 1;
		if(str1[i] != str2[i])
		{
			if(strcmp(&str1[i + 1], &str2[i]) == 0 || strcmp(&str1[i], &str2[i + 1]) == 0 || strcmp(&str1[i + 1], &str2[i + 1]) == 0)
				return 1;
			else
				return -1;
		}
	}
	return 0;
}
int main()
{
	int i;
	char str[20];
	string s;
	for(i = 0; scanf("%s", str); i++)
	{
		if(str[0] == '#')
			break;
		s = str;
		v.push_back(s);
	}
	for(; scanf("%s", str);)
	{
		if(str[0] == '#')
			break;
		bool f = 0;
		int q[51];
		int top = 0;
		for(i = 0; i < v.size(); i++)
		{
			int flag = mycmp(v[i].c_str(), str);
			if(flag == 1)
			{
				q[top ++] = i;
			//	printf("%s: %s\n", str, v[i].c_str());
			}
			else if(flag == 0)
			{
				f = 1;
				printf("%s is correct\n", str);
				break;
			}
		}
		if(f == 0)
		{
			printf("%s: ", str);
			int j;
			for(j = 0; j < top; j++)
			{
				printf("%s ", v[q[j]].c_str()); 
			}
			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值