poj1035 Spell checker

Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24391 Accepted: 8896

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
这个题就是给你一些字典中的单词,然后给你需要检查的单词,3种情况,如果可以直接找到就直接输出correct,否则的话可以找删除/替换/插入一个字母之后匹配的单词,然后全部输出。

此题直接暴力即可,按照3种情况分好,没什么问题。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <cstring>
#include <string>
using namespace std;
const int MAXN=10005;
char s[MAXN][20];
int l[MAXN];
int n,m;
void panduan(char *a)//寻找单词
{
    string ans;
    int la=strlen(a);
    int i,j;
    for(i=0;i<n;++i)
    {
        if(!strcmp(s[i],a))//匹配直接输出
        {
            printf("%s is correct\n",a);
            return ;
        }
//否则寻找另外3种情况
       if(l[i]==la)
       {
           int sum=0;
           for(j=0;j<la;++j)
           {
               if(a[j]==s[i][j])sum++;
           }
           if(sum==la-1)
           {
               ans+=' ';
               ans+=s[i];
           }
       }
       else
       if(l[i]==la-1)
       {
           int k=0;
           for(j=0;j<la;++j)
           {
               if(a[j]==s[i][k])k++;
           }
           if(k==l[i])
           {
               ans+=' ';
               ans+=s[i];
           }
       }
       else
       if(l[i]==la+1)
       {
           int k=0;
           for(j=0;j<l[i];++j)
           {
               if(a[k]==s[i][j])k++;
           }
           if(k==la)
           {
               ans+=' ';
               ans+=s[i];
           }
       }
    }
    cout<<a<<":"<<ans<<endl;
}


int main()
{

    n=0;
    char a[20];
    while(~scanf("%s",s[n]))
    {
        l[n]=strlen(s[n]);
        if(s[n][0]=='#')break;
        n++;
    }
    while(~scanf("%s",a))
    {
        if(a[0]=='#')break;
        panduan(a);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值