NYOJ 18-The Triangle

点击打开链接

The Triangle

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
样例输出
30

这是一道经典的动规问题,从上往下或者从下往上推都可以,我选择的是从上往下,输入完结果就出来了,每行的每个点,都选择上面两个点(能走到自己的只有两个点)中较大的一个,加上自己本身,并记录下来,最后遍历一遍最后一行的数取最大的数就是所求的结果

 
#include<stdio.h>
#include<vector>
using namespace std;
vector<int> tri[102];
int main()
{
	int n;
	scanf("%d", &n);
	int i, j;
	int num;
	scanf("%d", &num);
	tri[0].push_back(num);
	for(i = 1; i < n; i++)
	{
		scanf("%d", &num);
		tri[i].push_back(tri[i - 1][0] + num);
		for(j = 1; j < i; j++)
		{
			scanf("%d", &num);
			tri[i].push_back((tri[i - 1][j - 1] > tri[i - 1][j]? tri[i - 1][j - 1] : tri[i - 1][j]) + num);
		}
		scanf("%d", &num);
		tri[i].push_back(tri[i - 1][j - 1] + num);
		
	}	
	int max = -0x7fffffff;
	i--;
	for(j = 0; j < n; j++)
		if(max < tri[i][j])
			max = tri[i][j];
	printf("%d\n", max);
	return 0;
}        



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值