题目来源:http://acm.nyist.net/JudgeOnline/problem.php?pid=18
The Triangle
-
描述
-
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.-
输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. 输出
- Your program is to write to standard output. The highest sum is written as an integer. 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
样例输出
-
30
上传者
- 苗栋栋
//找出子问题 这题的子问题我开始以为是每一层作为一个子问题, 但是一想 影响最终结果的是全局最优解,
//每层的最优不能作为全局最优的前提,所以子问题应该是到达最后一行每一个点的最大值
//特别提醒下 用数组喜欢从下标0开始的同学, 为了刷题 尽量从1开始吧 很多算法中会出现 i -1这样的情况,就会访问到-1的下标
//虽然这样访问不会报错,但是我们不能让程序有隐患,而且从0开始有时候算法改起来真的麻烦,很容易考虑不全,当然只是我的感受。
# include <stdio.h>
# include <iostream>
using namespace std;
# define MaxRow 101
int map[MaxRow][MaxRow];
int dp[MaxRow][MaxRow];
int main()
{
int N, i, j, sum = 0;
freopen("in.txt", "r", stdin);
scanf("%d", &N);
for(i = 1; i <= N; i++){
for(j = 1; j <= i; j++){
//因为是自底向上的递推,所以其实就是从第一层开始计算,那么直接和输入合在一起了 这样省时 排名高一点 哈哈
scanf("%d", &map[i][j]);
dp[i][j] = max(dp[i-1][j-1], dp[i-1][j]);
dp[i][j] += map[i][j];
}
}
for(i = 1; i <= N; i++){
if(sum < dp[N][i]) sum = dp[N][i];
}
printf("%d\n", sum);
return 0;
}