The Triangle
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
4
-
描述
-
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
-
输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. 输出
- Your program is to write to standard output. The highest sum is written as an integer. 样例输入
-
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
样例输出
-
30
上传者
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[105][105];
int dp[105][105];//二维数组
int main()
{
int i,j,n,ans;
scanf("%d",&n);
for(i=1;i<=n;i++)//每层
for(j=1;j<=i;j++)
scanf("%d",&map[i][j]);//读入数据
for(i=1;i<=n;i++)
dp[n][i]=map[n][i];//将dp数组初始为最底层的各个值
for(i=n-1;i>=1;i--)//从倒数第2层往上处理
{
for(j=i;j>=1;j--)//每层的宽度,从右到左,当然也可以从左往右
dp[i][j]=map[i][j]+max(dp[i+1][j],dp[i+1][j+1]);
}
printf("%d\n",dp[1][1]);
return 0;
}