NYOJ 43-24 Point game,24点游戏:记忆搜索

点击打开链接

24 Point game

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No

题目没读,看样例输入和输出就知道是先输入所有数的个数,然后跟着输入所有的数,判断能不能构成24点

思路就是使用记忆化搜索,维护一个集合(数组实现),一开始只有起始的几个数 ,然后通过回溯每次取任意两个数进行加、减、乘、除、被减、被除6种操作,然后把结果放到集合中,并且在集合中删去之前操作的两个数,直到集合中只有一个数了,那么比较一下是不是24(注意因为过程中有除法的存在,这里就涉及到一个精度问题,多次运算过后可能会出现24.000001或者23.999999这种情况,所以要注意,不能单纯的(int)一下,在这我wa了一次)注:为什么被减和背除不能省略?b-a的话如果当前搜索位置是a,那么以后选择b的时候必会搜到b-a,为何要在选择b的时候就搜索b被a减?答:这个算法当中每次选择的是一对数,两个数没有顺序关系,就是说如果选择了a和b两个数运算,那么就要执行完所有a和b能存在的运算,因为以后再也不会同时选择a和b运算了。

 
#include<stdio.h>
#include<string.h>
double array[11];
int used[11];
int m, result;
int top;
int dfs(int number)
{
	int i, j;
	if(number == 1)
	{
//		printf("%lf\n", array[top - 1]);

		if(array[top - 1] - result < 1E-6 && array[top - 1] - result > -1E-6 )//处理精度
			return 1;
		else
			return 0;
		
	}
	for(i = 0; i < top - 1; i++)
	{
		if(used[i] == 0)
		{
			used[i] = 1;
			for(j = i + 1; j < top; j++)
			{
				if(used[j] == 0)
				{
					used[j] = 1;
					array[top++] = array[i] + array[j];
					if(dfs(number - 1) == 1)
						return 1;
					array[top - 1] = array[i] - array[j];
					if(dfs(number - 1) == 1)
						return 1; 
					array[top - 1] = array[i] * array[j];
					if(dfs(number - 1) == 1)
						return 1;
					array[top - 1] = array[j] - array[i];
					if(dfs(number - 1) == 1)
						return 1;
					if(array[i] != 0)
					{
						array[top -1] = array[j] / array[i];
						if(dfs(number - 1) == 1)
							return 1;
					}
					if(array[j] != 0)
					{
						array[top - 1] = array[i] / array[j];
						if(dfs(number - 1) == 1)
							return 1;
					}
					top -- ;
					used[j] = 0;
				}
			}
			used[i] = 0;
		}
	}
	return 0;
}
int main()
{
//	freopen("test.txt", "r", stdin);
	int n;
	scanf("%d", &n);
	while(n--)
	{
		scanf("%d %d", &m, &result);
		memset(used, 0, sizeof(used));
		int i;
		top = m;
		for(i = 0; i < m; i++)
		{
			scanf("%lf", &array[i]);
		}
		if(dfs(m) == 1)
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}        


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

勇敢的炮灰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值