nyoj-43 24 Point game 记忆搜索

 

24 Point game

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 5
 
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

 
输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
代码:
#include<stdio.h>
#include<math.h>
const double e = 1e-6; 
double num[7],v;
int n;
bool dfs(int t)
{
    if(t==n)
    {
        if(fabs(v-num[n])<e)
            return true;
        return false;
    }
double left,right;
    for(int i=t;i<n;++i)
        for(int j=i+1;j<=n;++j)
        {
            left=num[i];
            right=num[j];
            num[i]=num[t];
            num[j]=left+right;    if(dfs(t+1)) return true;
            num[j]=left-right;    if(dfs(t+1)) return true;
            num[j]=left*right;  if(dfs(t+1)) return true;
            num[j]=right-left;  if(dfs(t+1)) return true;
            if(left) 
                num[j]=right/left; if(dfs(t+1)) return true;
            if(right)
                num[j]=left/right; if(dfs(t+1)) return  true;
            num[i]=left;//回溯
            num[j]=right;
        }
    return false;
}




int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%lf",&n,&v);
        for(int i=1;i<=n;++i)
            scanf("%lf",&num[i]);
        if(dfs(1))
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


 

转载于:https://www.cnblogs.com/zibuyu/archive/2013/05/29/3106963.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值