ZOJ3410--Layton's Escape

Description

Professor Layton is a renowned archaeologist from London's Gressenheller University. He and his apprentice Luke has solved various mysteries in different places.

layton.jpg

Unfortunately, Layton and Luke are trapped in a pyramid now. To escape from this dangerous place, they need to pass N traps. For each trap, they can use Ti minutes to remove it. If they pass an unremoved trap, they will lose 1 HP. They have K HP at the beginning of the escape and they will die at 0 HP.

Of course, they don't want trigger any traps, but there is a monster chasing them. If they haven't pass the ith trap in Di minutes, the monster will catch and eat them. The time they start to escape is 0, and the time cost on running will be ignored. Please help Layton to escape from the pyramid with the minimal HP cost.

Input

There are multiple test cases (no more than 20).

For each test case, the first line contains two integers N and K (1 <= N <= 25000, 1 <= K <= 5000), then followed by N lines, the ith line contains two integers Ti and Di (0 <= Ti <= 10^9, 0 <= Di <= 10^9).

Output

For each test case, if they can escape from the pyramid, output the minimal HP cost, otherwise output -1.

Sample Input

3 2
40 60
60 90
80 120
2 1
30 120
60 40

Sample Output

1
-1
屯道题。。经典贪心。
按die排序,必须掉血的时候,在堆中拿最大cost那个。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
#define maxn 25080
#define LL long long int
struct Job
{
	LL cost,die;
}job[maxn];
struct Node
{
	LL cost;
	bool operator < (const Node & a)const
	{
		return cost < a.cost;
	}
};
bool cmp(Job j1,Job j2)
{
	if(j1.die != j2.die)	return j1.die < j2.die;
	else return j1.cost > j2.cost;
}
int gao(int n,int k)
{
	priority_queue <Node> q;
	LL nowtime = 0;
	for(int i = 1;i <= n;i++)
	{
		if(nowtime + job[i].cost <= job[i].die)
		{
			Node fuck;
			fuck.cost = job[i].cost;
			q.push(fuck);
			nowtime += job[i].cost;
		}
		else 
		{
			Node temp;
			temp.cost = job[i].cost;
			nowtime += job[i].cost;
			q.push(temp);
			while(nowtime > job[i].die && !q.empty())
			{
				Node temp1 = q.top();
				q.pop();
				nowtime -= temp1.cost;
				k--;
			}
		}
	}
	return k;
}
int main()
{
	//freopen("in.txt","r",stdin);
	int n,k;
	while(scanf("%d%d",&n,&k)==2)
	{
		for(int i = 1;i <= n;i++)
		{
			scanf("%lld%lld",&job[i].cost,&job[i].die);
		}
		sort(job+1,job+1+n,cmp);
		int a = gao(n,k);
		if(a <= 0) cout << -1 << endl;
		else cout << k - a << endl;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值