POJ1160--Post Office(四边形不等式优化)

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

题意:从n个城市选m个做office.使得所有城市距离最近的office的和最小

思路:先排序,dp[i][j]表示前j个城市里面挑i个使得前j个城市最优.

    很容易想到转移方程dp[i][j] = dp[i-1][k]+w[k+1][j];

    这样复杂度是n^3的.然后就是四边形不等式优化降为n^2..

    这里讲得很详细:http://blog.csdn.net/shiwei408/article/details/8791011

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <vector>
#include <cmath>
#include <queue>
using namespace std;
#define inf 0x3f3f3f3f
int dp[38][328];
int s[38][328];
int w[328][328];
int a[328];
int sum[328];
int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);
	int n,m;
	while(scanf("%d%d",&n,&m)==2)
	{
		for(int i = 1;i <= n;i++)
			scanf("%d",&a[i]);
		sort(a+1,a+1+n);
		sum[0] = 0;
		for(int i = 1;i <= n;i++)
			sum[i] = sum[i-1] + a[i];
		for(int i = 1;i <= n;i++)
			s[1][i] = 0;
		for(int i = 1;i <= n;i++)
		{
			for(int j = 1;j <= n;j++)
			{
				if(i == j)	w[i][j] = 0;
				else 
				{
					int pos = (i+j)/2;
					w[i][j] = (pos-i)*a[pos]-(sum[pos-1]-sum[i-1])+(sum[j]-sum[pos])-(j-pos)*a[pos];
				}
			}
		}
		memset(dp,0x3f,sizeof(dp));
		for(int i = 1;i <= n;i++)	dp[1][i] = w[1][i];
		for(int i = 2;i <= m;i++)
		{
			s[i][n+1] = n;
			for(int j = n;j >= 1;j--)
			{
				for(int k = s[i-1][j];k <= s[i][j+1];k++)
				{
					if(dp[i-1][k] + w[k+1][j] < dp[i][j])
						s[i][j] = k;
					dp[i][j] = min(dp[i][j],dp[i-1][k]+w[k+1][j]);
				}
			}
		}
		printf("%d\n",dp[m][n]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值