POJ3259--Wormholes--Bellman-Ford算法经典题

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
//此题说白了就是寻找负环,我的做法是枚举顶点,将顶点所能达到的点标记。然后不断枚举未标记的顶点。
//看了下DISCUSS,发现弄个超级源点,连接所有顶点,边权为0.只需一次Bellman-Ford.神奇。。。
#include <iostream>
#include <cstdio>
using namespace std;
#define inf 0x3f3f3f3f
#define maxn 5500
int u[maxn],v[maxn],w[maxn];//u存边的起点,v存边的终点,w存边长
int d[506];
int dd[506];
bool vis[506];
inline int min(int a,int b)
{
	return a>b?b:a;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		bool flag=false;
		memset(w,0x3f,sizeof(w));
		memset(d,0x3f,sizeof(d));
		memset(vis,0,sizeof(vis));
		int n,m,hole;
		scanf("%d%d%d",&n,&m,&hole);//有m条路,hole个虫洞
		int edge=m+hole;
		int start,end,len;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&start,&end,&len);
			u[i]=v[edge+i]=start;
			v[i]=u[edge+i]=end;
			w[i]=w[edge+i]=len;
		}
		for(int i=m+1;i<=m+hole;i++)
		{
			scanf("%d%d%d",&start,&end,&len);
			u[i]=start;
			v[i]=end;
			w[i]=-len;
		}
		for(int j=1;j<=n;j++)
		{
			if(vis[j])continue;
			for(int i=1;i<=n;i++)
			{
				d[i]=inf;
			}
			d[j]=0;
			vis[j]=1;
			int alledge=2*m+hole;
			for(int k=1;k<n;k++)
			{
				for(int i=1;i<=alledge;i++)
				{
					int x=u[i],y=v[i];
					if(d[x]<inf)
					{
						d[y]=min(d[x]+w[i],d[y]);
						if(w[i]<inf)
						{
							vis[y]=1;
						}
					}
				}
			}
			for(int i=1;i<=n;i++)
			{
				dd[i]=d[i];
			}
			for(int i=1;i<=alledge;i++)
			{
				int x=u[i],y=v[i];
				if(d[x]<inf)
				{
					d[y]=min(d[x]+w[i],d[y]);
					if(w[i]<inf)
					{
						vis[y]=1;
					}
				}
			}
			for(int i=1;i<=n;i++)
			{
				if(d[i]!=dd[i])
				{
					flag=true;
					goto L;
					break;
				}
			}
		}
		L:
		if(flag)
		{
			cout<<"YES"<<endl;
		}
		else cout<<"NO"<<endl;
	}
	return 0;
}
下面是我后来做的,用超级源点。时间空间都有所下降。。
#include <iostream>
#include <cstdio>
using namespace std;
#define inf 0x3f3f3f3f
#define maxn 5500
int u[2*maxn],v[2*maxn],w[2*maxn];//u存边的起点,v存边的终点,w存边长
int d[506];
bool vis[506];
inline int min(int a,int b)
{
	return a>b?b:a;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		bool flag=false;
		memset(w,0x3f,sizeof(w));
		memset(d,0x3f,sizeof(d));
		memset(vis,0,sizeof(vis));
		int n,m,hole;
		scanf("%d%d%d",&n,&m,&hole);//有m条路,hole个虫洞
		int edge=m+hole;
		int start,end,len;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&start,&end,&len);
			u[i]=v[edge+i]=start;
			v[i]=u[edge+i]=end;
			w[i]=w[edge+i]=len;
		}
		for(int i=m+1;i<=m+hole;i++)
		{
			scanf("%d%d%d",&start,&end,&len);
			u[i]=start;
			v[i]=end;
			w[i]=-len;
		}
		for(int i=2*m+hole+1;i<=2*m+hole+n;i++)
		{
			u[i]=n+1;
			v[i]=i-2*m-hole;
			w[i]=0;
		}
		d[n+1]=0;
		for(int i=1;i<n+1;i++)
		{
			for(int j=1;j<=2*m+hole+n;j++)
			{
				int x=u[j],y=v[j];
				if(d[x]<inf)
				{
					d[y]=min(d[y],d[x]+w[j]);
				}
			}
		}
		for(int j=1;j<=2*m+hole+n;j++)
		{
			int x=u[j],y=v[j];
				if(d[x]<inf)
				{
					if(d[x]+w[j]<d[y])
					{
						flag=true;
						break;
					}
				}
		}
		if(flag)printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值