POJ2151--Check the difficulty of problems

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972
/*
  orz........题表上把此题归为HASH??? 
  看了题解才知道此题是DP。。。DP巨弱的跪了~~~~~~
  m:问题数目 上限30
  t: 队伍数目 上限1000
  n: 冠军队伍最少应该完成的题数
  此题求冠军队伍最少完成n题的概率和所有的队伍都能够完成至少1道题目的概率
  第二个问题只需求出每个队伍一题没A的概率,1-之。得到每个队伍有A题的概率,累乘即可
  问题所求概率=每队至少A一题的概率-所有队做题数都在1到N-1之间的概率(冠军队有可能不只1支)
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
double A[1008][31];//各队A各题的概率
double B[1008][31][31];//各队在前多少题中A几题的概率
int main()
{
	int m,t,n;
	while(scanf("%d%d%d",&m,&t,&n)==3&&(m||t||n))
	{
		memset(A,0,sizeof(A));
		memset(B,0,sizeof(B));
		for(int i=1;i<=t;i++)
		{
			for(int j=1;j<=m;j++)
			{
				scanf("%lf",&A[i][j]);
			}
		}//各队A各个题的概率存好
		for(int i=1;i<=t;i++)
		{
			for(int j=1;j<=m;j++)
			{
				B[i][0][0]=1;
				B[i][j][0]=B[i][j-1][0]*(1-A[i][j]);
			}
		}
		for(int i=1;i<=t;i++)
		{
			for(int j=1;j<=m;j++)
			{
				for(int k=1;k<=m;k++)
				{
					B[i][j][k]=B[i][j-1][k-1]*A[i][j]+B[i][j-1][k]*(1-A[i][j]);
				}
			}
		}//每对在前30道题A几题的概率已经算出来
		//接下来算每队至少A一题的概率
		double p1=1.;
		for(int i=1;i<=t;i++)
		{
			p1*=(1-B[i][m][0]);
		}
		//接下来算每队的做题数都在1到N-1之间的概率
		double p2=1.;
		for(int i=1;i<=t;i++)
		{
			double pp=0;
			for(int j=1;j<n;j++)
			{
				pp+=B[i][m][j];
			}
			p2*=pp;
		}
		printf("%.3lf\n",p1-p2);
	}
	return 0;
}
		

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值