Check the difficulty of problems
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7733 Accepted: 3304
Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.
Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.
Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?
Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0
Sample Output
0.972
给你m支队伍,t个问题,n,
接下来是m行,分别代表每支队伍对每个问题的解出概率
、
现在要求:使得每支队伍最少解决一道题且冠军队伍至少解决n道题寄概率
分析:
dp[i][j][k]表示第i队伍前j个题做出k个的概率,dp[i][0][0]=1,dp[i][j][0]=dp[i][j-1][0](1-a[i][j]),dp[i][j][k]=dp[i][j-1][k-1]*a[i][j]+dp[i][j-1][k](1-a[i][j]);
s[i][j]表示第i个队伍做出小于等于j道题的概率,s[i][0]=dp[i][m][0],s[i][j]=s[i][j-1]+dp[i][m][j];
这样就能算出∑ p1*=(1-s[i][0])为至少做出一道的概率,算出∑ p2*=(s[i][n-1]-s[i][0])为每个队伍做出1~n-1道的概率,相减就是每个队伍最初一道且至少有一只队伍做出n道的概率了
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <cmath>
using namespace std;
float dp[1024][32][32],s[1024][32];
///dp[i][j][k]表示第i队伍前j个题做出k个的概率,dp[i][0][0]=1,dp[i][j][0]=dp[i][j-1][0]*(1-a[i][j]),dp[i][j][k]=dp[i][j-1][k-1]*a[i][j]+dp[i][j-1][k]*(1-a[i][j]);
///s[i][j]表示第i个队伍做出小于等于j道题的概率,s[i][0]=dp[i][m][0],s[i][j]=s[i][j-1]+dp[i][m][j];
///这样就能算出∑ p1*=(1-s[i][0])为至少做出一道的概率,算出∑ p2*=(s[i][n-1]-s[i][0])为每个队伍做出1~n-1道的概率,相减就是每个队伍最初一道且
///至少有一只队伍做出n道的概率了
int m,t,n;
float a[1024][32];
int main()
{
while(~scanf("%d %d %d",&m,&t,&n)&&m&&n&&t)
{
memset(dp,0,sizeof(dp));
//memset(p,0,sizeof(p));
memset(s,0,sizeof(s));
for(int i=1; i<=t; i++)
{
//dp[i][0][0]=1;
for(int j=1; j<=m; j++)
{
scanf("%f",&a[i][j]);
//dp[i][j][0]*=(1-a[i][j]);
}
}
for(int i=1; i<=t; i++)
{
dp[i][0][0]=1;
for(int j=1; j<=m; j++)
{
dp[i][j][0]=dp[i][j-1][0]*(1-a[i][j]);
//s[i][t]+=dp[i][m][j];
}
for(int j=1; j<=m; j++)
{
for(int k=1; k<=j; k++)
{
dp[i][j][k]=dp[i][j-1][k-1]*a[i][j]+dp[i][j-1][k]*(1-a[i][j]);
}
}
s[i][0]=dp[i][m][0];
for(int j=1; j<=m; j++)
{
s[i][j]=s[i][j-1]+dp[i][m][j];
}
}
double p1=1,p2=1;
for(int i=1; i<=t; i++)
{
p1*=(1-s[i][0]);
p2*=(s[i][n-1]-s[i][0]);
}
//if(n==1) p2=0;
printf("%.3f\n",p1-p2);
}
return 0;
}